Difference between revisions of "BetteRoll20 Install"

From 5etools Community Wiki
Jump to: navigation, search
m
m
Line 58: Line 58:
  
 
===What to do if your script will not update.===
 
===What to do if your script will not update.===
<div class="toccolours mw-collapsible mw-collapsed" style="width:600px; overflow:auto;">
+
<div class="toccolours mw-collapsible mw-collapsed" style="overflow:auto;">
 
<div class="mw-collapsible-content">
 
<div class="mw-collapsible-content">
 
(All of the following assume that you've not modified the default Tampermonkey settings. To Make sure when you click on a link it works (in Chrome)  
 
(All of the following assume that you've not modified the default Tampermonkey settings. To Make sure when you click on a link it works (in Chrome)  
Line 94: Line 94:
  
 
===Manually Updating the Script===
 
===Manually Updating the Script===
<div class="toccolours mw-collapsible mw-collapsed" style="width:600px; overflow:auto;">
+
<div class="toccolours mw-collapsible mw-collapsed" style="overflow:auto;">
 
<div class="mw-collapsible-content">
 
<div class="mw-collapsible-content">
 
This can be a bit technical for the unfamiliar. For this you will need a simple text editor. A simple text editor (such as Windows Notepad) will not offer to format text (no bold, italics, Colors, or even fonts).  
 
This can be a bit technical for the unfamiliar. For this you will need a simple text editor. A simple text editor (such as Windows Notepad) will not offer to format text (no bold, italics, Colors, or even fonts).  

Revision as of 19:30, 21 July 2019

framless
v1.16.11


Overview: The BetteR20 script works to modify the local session of Roll20's platform. While some of the script's abilities will seem to change Roll20, it more works as an interpreter changing what you see or it works behind the scenes taking actions as if you yourself had taken various steps. 



Getting Started/Checking your system

1️⃣ You must have either Chrome or Firefox as the browser.

You cannot use Waterfox, or Chrome for Opera, Internet Explorer, etc.

2️⃣ The Install must be the most current version of either.

3️⃣ It cannot be on a mobile/tablet device.

Getting the right tools

1️⃣ Install TamperMonkey  (for Chrome / Firefox ) on your browser

2️⃣ Confirm it is installed (you may need to close all session of the browser and restart the browser)

3️⃣ Install R20ES

The Script(s)

Get5eToolscom.png

There are two scripts, Better20 core and Better20 5eTools Go to Get.5eTools.com 

  • Choose which script you'll be using
  • Core (General UI features - not specific to 5e games)
  • 5eTools (Which already includes core + a set of 5eTools specific features)
  • If you install both - ensure only one BetteR20 script is enabled. (You may install both. It's not suggested. and You can only have one active)
  • Click on either BetteR20 Core or BetteR20 5eTools at the Get.5eTools.com  site.(versions will likely be different on the live site)


If things are set up correctly, you should get a screen like this:

(for new installs)

thumb

(for attempting to update via file link after installation the script, unless modified, or prevented by the user, should automatically update)

Forced Update


In the tampermonkey dashboard you should see a listing for the for the script you've chosen with the enabled toggle next to as green (ie enabled)

  • Head over to Roll20 and test if its working properly. If it is you'll see a message like this in the chat window.
Example notification

NOTE: The Versions of TamperMonkey and the script may have udpated since the photo was taken, both tampermonkey and BetteR20 will automatically update as new versions become available.


Now is a great time to...Give Thanks.







What to do if your script will not update.

(All of the following assume that you've not modified the default Tampermonkey settings. To Make sure when you click on a link it works (in Chrome)

Go into Chrome -> More Tools -> Extensions, then in the Tampermonkey section -> Details and under Site Access, click "On All Sites".


1️⃣ Confirm you have the latest version of (non beta) tampermonkey

2️⃣ Confirm you have the lastest of either FF or Chrome browsers (all other browsers, waterfox, opera, etc etc are not supported)

3️⃣ Confirm you are using only one instance of the Better20 script at a time. (delete others you are not using)

4️⃣ Go to https://get.5etools.com

does that work? (can you install the script? (see installation notes above)
if so. go no further, if not...

5️⃣Go to https://get.5e.Tools

does that work? (can you install the script? (see installation notes above)
if so. go no further, if not...

6️⃣ CTRL + F5

7️⃣ copy this https://get.5e.tools/script/betteR20-5etools.user.js?v=

paste it to the address bar in your browser, type something random -ie keyboard mash (example: `232qv5q3asdhiou9ajlk` or `mrtootsbutts`) at the end of that address
does that work? (can you install the script? (see notes above)
if so. go no further, if not...

8️⃣ Delete the script from tampermonkey's dashboard and try again from step 1 (ignoring this step on the second pass)

does that work? (can you install the script? (see notes above)
if so. go no further, if not...


Manually Updating the Script

This can be a bit technical for the unfamiliar. For this you will need a simple text editor. A simple text editor (such as Windows Notepad) will not offer to format text (no bold, italics, Colors, or even fonts).

🛆 If prompted to download the `.js` script, note the file name (often betteR20-<either core/5etools>-user.js, and then open it in a simple text editor

🛆 If the browser just shows the code.

Check to make sure Tampermonkey is installed, enabled and current.
If Chrome, make sure that in Chrome
> More Tools
> Extensions, then under
> Tampermonkey
> find the Details and under Site Access,
> click "On All Sites"
Copy the code presented to the browser into a simple text editor.

▶️Open Tampermonkey's Dashboard

right click tampermonkey,
choose dashboard

▶️Click the plus sign tab which will open the <New Userscript> Editor.

▶️Delete the prepopulated script code in the editor.

click in the text field and ctrl+A then delete, or
click at the beginning or end of the pre-populated text and hold down Del or Backspace until the text is erased.

Paste the code into tampermonkey's editor.

Click on and change <New Userscript> to betteR20- and then either core if using core, or 5etools if using the full tools.

Under File, -> Save

Trouble Shooting a Failed/Not working Installation of the script

FOLLOW THESE INSTRUCTIONS CAREFULLY AND EXACTLY

Confirm you not done the following

BetteR20 Loading.png

DO NOT...

disable or fail to install the R20ES (VTT Enhancement Suite), (see installation notes above). If you do not do this, Roll20 will hang upon loading you MUST have the extension Installed and enabled . 







BetteR20 DUAL install.png

DO NOT...

have both BetteR20 Core & BetteR20 5eTools enabled at the same time. If you do... you'll hang on load and get an error.









Roll20 no API.png

DO NOT...

DO NOT take put the RAW text of the script's code into Roll20's API Scripts as an "untitled.js."

(if that means nothing to you, don't worry. Its only possible to make this mistake if you have a Roll20 Pro level subscription.. and the tampermonkey script is not a Roll20 API Script)









Isolation Troubleshooting

Identify and isolate the problem so it's reproducible.

Determine if its a Roll20 Specific Issue, A R20ES/VTT ES issue or a BetteR20 Issue

👉 Make sure you are using the current browser version.

👉 Make sure you are using the most current extension versions (R20es/VTT es & Tampermonkey) and have the most current version of the BetteR20 Script (if you are using it)

👉 Don't keep entering into the same game. Make sure your efforts to see what is happening include attempting the same in other games (even if you have to create a game to test.) and try it as both GM and Player.

👉 Don't fail to try Firefox and Chrome in your identification steps -

ie if its happening in your favorite browser try seeing what happens in the one that isn't your favorite.

👉 Try Uninstalling and reinstalling the VTT ES (R20ES) extension, Tampermonkey and the script.


1️⃣ CTLR + F5 - force refresh of site/code

2️⃣ Restart Browser.

3️⃣ Disable other extensions - Disable all other extensions or scripts beyond R20ES/VTT ES & Tampermonkey which should be only running one instance of the script as active.

Then attempt to reproduce, cause the error to occur again.
If you cannot, its something outside of the script - add things back one at time until the error presents and then report that to discord community (link under Support>Community)

4️⃣ Disable Tampermonkey - to that and do a ctrl + F5. If the problem or setting(s) you are attempting to work with are still present, the issue resides outside of Better20.

5️⃣ Disable R20ES / VTT ES - attempt to use Roll20 without it. (It may be that Roll20 has something going on with it independently.

If the problem persists, its a Roll20 issue.
If it does not, it a R20ES / VTT ES issue and should be reported to that discord's 'Issue' (see below)

6️⃣ Reporting - Once you've determined that there is a problem, how to reproduce it, and what system is causing it. Report it. To the correct location.

if it happens only with Tampermonkey and BetteR20 script enabled - go to 5eTool's Discord channel for Roll20
if it happens only with R20ES / VTT ES enabled go to their Discord channel for issues-and-support.
if it happens in Roll20 without anything else loaded, check the forums for it being reported. check with 5eTool's Roll20 channel and see if there is a workaround already.

In both cases provide the following:

Copy and fill out the segment below and paste it to the relevant group.

ISSUE: a brief summary of the issue
STEPS: what you need to do to generate it
BROWSER: what browser and version you are using
EXTENSION(s): what extensions are you running when the error presents.
CONSOLE: copy of what the console or error message(s) show

🖥️ You may not know how to get console error messages. To find and retrieve them, hit f12 and then make sure console is selected. the messages that are in Red are the ones being sought.

Specify EVERYTHING,

saying "current version" doesn't mean you are using the current version, knowing what the current version is by stating it, does indicate that you've checked and confirmed such.

Use to https://www.whatismybrowser.com/ check if what you're using really is. *(and.. The ESR isn't the latest release, and it's often not the supported release)

saying "I did that", doesn't mean you did - often (to be honest) it means, "yeah, yeah, I'm sure its not whatever basic things you're saying to do, I'm already sure my problem is specific/unique" - and often, they are not, and the basic troubleshooting processes resolve them. Please state specifically what you did. Typing that out is a pain - for both sides of support - but, doing in when reporting an issue means the person supporting you can get to the heart of the matter versus walking you thru the stuff you've already done, and haven't documented.


Now you may wish to familiarize yourself with:

Better20 Script's Features

VTT es Extension's Features

Roll20 (only better) FAQ